Momentum Dashboard

2

Focus on search bar with new tab

Answered

Comments

6 comments

  • Official comment
    Avatar
    Ben Wilson

    Hello Nicolas,

    Thanks for reaching out.

    Unfortunately, this is a Firefox related bug and there isn't anything we can do to fix it. We have filed a bug report with Firefox and are hoping to see it resolved soon!

    With that being said, it appears that this bug can be avoided by viewing Firefox in windowed mode, rather than full-screen mode. Can you confirm whether or not windowed mode avoids this bug on your end as well?

    Thanks again for trying out the Firefox version of Momentum. If you encounter any other problems, please let us know. 

    Cheers,

    Ben

  • Avatar
    Nicolas

    Hello Ben,

    You are right, switching Firefox to windowed-mode avoid the issue. I hope Firefox will fix the it soon.

    Thank you,

  • Avatar
    Kahlil

    Had the same problem with Firefox Dev edition on MacOS and the workaround of using it windowed instead of full-screen seems to work for now. Extremely irritating bug though :/

  • Avatar
    Los Armandos

    It is a noob bug, with Momentum off there's no issue, even in fullscreen it will open new tabs with adressbar focus but with Momentum i've got this issue and i don't want to use Firefox in Windows mode cause Momentum team is not able to fix this problem. I'm happy that i didn't pay for this extension.

  • Avatar
    Bijan

    The loss of address/search bar focus when opening a new Firefox Quantum window started happening for me in the last few weeks. This loss of functionality seems to coincide with the Momentum release that included ToDo lists. I've disabled the ToDo list feature, but am still seeing an issue.

    I've tried opening a new window in both windowed-mode as well as full screen mode and in both cases the address/search bar focus is not happening automatically (I either click in the address/search bar or <command>-L to get the focus... absolutely not my preference...).

    When opening a new Firefox tab this problem is not happening. When opening a new tab (<command>-T) the address/search bar focus works. Only seems to be a problem with opening new windows (<command-N>) which I do very frequently, so this is a big issue for me.

    Disabling the Momentum extension makes this problem go away.

    Maybe a Firefox bug, but I would strongly suggest looking at recent changes in the Momentum code to see what changed in the recent release to cause this issue. Things were working swimmingly until now.

    Details:  Firefox Quantum 61.0.1 (64-bit) running on MacOS 10.11.6

     

    Also, I tried this running Chrome (67.0.3396.99 64-bit) and things are working okay there. No problems with focus with new windows or new tabs.

     

     

    Any update on the status of this request?

  • Avatar
    Otto

    I experience the same behavior as Bijan. This is a different to the original report so thought I'd raise a new issue for it; https://get.momentumdash.help/hc/en-us/community/posts/360017840534-Focus-on-search-bar-with-new-window

Please sign in to leave a comment.